Orders

Error: This feature is not enabled or not available in this version of QuickBooks.

How to remedy QuickBooks error "This feature is not enabled or not available in this version of QuickBooks."

Description

When attempting to sync new transactions to QuickBooks, QuickBooks returns the following error message to Connex:

"Error: This feature is not enabled or not available in this version of QuickBooks."

Cause

Transactions are failing to sync to QuickBooks because QuickBooks is instructing Connex that a specific feature is not enabled or not available with the version of QuickBooks that is running. 

Solution(s)

Update to the Latest Version of QuickBooks

Ensure that you're running the most recent version of QuickBooks Pro, Premier, or Enterprise

This may not solve all instances of this issue, as some features require QuickBooks Enterprise that are not available with QuickBooks Pro or QuickBooks Premier.

Change your transaction mode

If you asked Connex to sync sales orders or estimates, ensure you can create sales orders and estimates in QuickBooks. If that option is unavailable, change your Connex transaction mode:

  1. Login to Connex.
  2. Click manage.
  3. Expand orders > transaction.
  4. Choose sales receipts.
  5. Click save.

Ensure Sales Order or Estimates is enabled

You will need to enable creating estimates in QuickBooks to fix this error.

In QuickBooks click on Edit and then Preferences. 

As shown above, click Jobs & Estimates and then Company Preferences.

Under "Do you create estimates?" Change from No to Yes.

Disable inventory and sites

If you asked Connex to create inventory sites and bins, ensure you can map sites and bins in your QuickBooks. If not, disable this setting inside of Connex:

  1. Login to Connex.
  2. Click manage.
  3. Expand inventory > sites and bins.
  4. Clear all the drop downs.
  5. Click save.

Alternatively, ensure that inventory sites are set up and enabled within QuickBooks.

Disable multi-currency

Ensure you are mapping no currency codes to QuickBooks, if multi-currency is disabled in QuickBooks:

  1. Login to Connex.
  2. Click manage.
  3. Expand customers > advanced customer.
  4. Disable multi-currency.
  5. Click save.

Ensure you are syncing invoices and payments once

In rare circumstances, you can ask Connex to sync the same invoice and payment at the same time. Connex tries to pay the same invoice twice. Follow these steps:

  1. Login to Connex.
  2. Click manage.
  3. Expand orders > sync orders to QuickBooks > sync manually to QuickBooks.
  4. Clear the order status field or use a single status.