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  2. General Troubleshooting Guide
  3. QuickBooks Desktop Error Messages

Error: Could not open the specified QuickBooks company data file

What to do if you encounter the desktop QuickBooks "Could not open the specified QuickBooks company data file" error.

Description

When attempting to run the desktop QuickBooks Web Connector tool, the following error is encountered:

WebMethod: connectionError() has been called by QBWebconnector13101310Parameters received:1310string ticket = 3ac8d4db-c6ba-4bc2-92a9-526a6cf13ba61310string hresult = 0x800404031310string message = Could not open the specified QuickBooks company data file.13101310HRESULT = 0x800404031310Message = Could not open the specified QuickBooks company data file.1310Sending DONE to stop.1310Return values: 1310string retVal = DONE1310

Cause

There can be any number of reasons why this message may be encountered. Below, you'll find several fixes to common company file-related issues. Generally speaking, this error typically means that the Web Connector lacks the proper permissions to access your company file; the company file pathway is incorrect and must be updated; or a different company file is open than the one expected.

Solutions

The following solutions are the step as recommended by Intuit. If these steps do not work, please contact Intuit support.

Step 1: Update QuickBooks

If you haven’t already, update QuickBooks Desktop to the latest release.

Step 2: Check the file you’re opening

There are a lot of file types in QuickBooks Desktop. You need to open a company file (QBW) with a .qbw extension at the end of the filename.

You can't open other file types, like backups (QBB) and portable files (QBM), the same way.

Step 3: Ensure the correct company file is open

Double-check to ensure that the correct QuickBooks company file is open.

Step 3: Double-check the file path

With QuickBooks open, press F2. This will launch the desktop QuickBooks product information. Here, you'll find the company file path.

Next, login to Connex. On the dashboard, click Settings; next, select Advanced and scroll until you find the field marked "file path". Here, you can view the company file path with which Connex is integrated. Update, if different.