Error: Application requested to abort

Description

When running the Web Connector, the Web Connector fails to update resulting in the following error message:

"Version:

1.0

 Message:

Application requested to abort

Description:

Error connecting to QuickBooks. Error message received from QuickBooks was <This application has not accessed this QuickBooks company data file before. The QuickBooks administrator must grant an application permission to access a QuickBooks company data file for the first time.>. Application has sent back a DONE via connectionError. More information in available in the log file (click View Log button from main window). Update aborted per request from application."

Cause(s)

This typically means that the Web Connector is having problems correctly connection to your QuickBooks company file.

In the Web Connector, click the blue hyperlink for "Click for more information" to launch the Web Connector log and view the detailed activity. Likewise, this log can be copied + pasted into a notepad file and sent to our support for review.

Solution(s)

Company File

Login to QuickBooks as administrator and open your company file. If the file is closed, you can receive this error.

Dialog Window

In QuickBooks, ensure no windows asking for yes/no or OK are open.

Administrator Can Grant Permission

In the Connex transaction log, you will see this error message:

This application is not allowed to log into this QuickBooks company data file automatically. The QuickBooks administrator can grant permission for an automatic login through the Integrated Application preferences.

This means you paired our app and QuickBooks as a non admin user. You must login as admin and give it permissions. Here are the steps:

  1. Login to QuickBooks as Admin.
  2. Open the web connector.
  3. On the left, check the boxes for all the Connex connections. If you only have one connection, then check the box.
  4. Click update selected.
  5. QuickBooks will prompt you for permissions. Select the fourth radio button. If you see a drop down, select Admin.
  6. Click OK.

If this fails, follow these steps:

  1. Login to QuickBooks as Admin.
  2. Go to Edit>Preferences>Integrated Applications>Company Preferences>Select Connex>Select Reauthorize
  3. Uncheck the box that prevents applications from accessing the current company file: edit_permissions.png
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